í«îÛpython3-jwcrypto-0.7-bp157.2.6.1Ž­è<>,èêì6‰j—î(ŠIë%Ûzà PLý€;¢œÕT§ë¼`‹¿¨ÏÃq3‰P›Ey!ŸÐãbÅ̱½ìÎcÊä"6U�¥žØˆ°d(ëÐgè`Ó³WBË•^ÚÔ+z\œ‘ž(€Ù¸ºP‚¸£p3]ªŽÖ"+`Áä}VêrÇTÙOލ”á N*í<(=¿êËÓ¶f�„ã›»×/ Có¢ðÿ&-G5Ü‹Á~µ*K#;îÑ&¹²æ^EO=Ö–W¸»÷¸V)œS²:̵� –‰†¶fßÝ4%'sðlÛó^V€äjS6×® ”Û+›BÙf8çc)=hR~:Bî¬w€>50!0ãÅMBM_N‰ƒ¹d£Àcè#0Vîq×fì×Ò��j|h$Ñ$åŸÿÿÿÀŽ­è>#€?#pdèéêì #í Yîœï ñ¬ò°óÉöÒ÷àø ùüý;þAH'ä' 2' €' '  Ã'  ì' ˆ'K'8'Ôè¤(Í8Ô 9 :< FÒGè'H„'I 'XHYL\\']ø'^¬bìc§d Ve [f ^l `u t'v!w!l'x"'y"¤z#“# Æ#$ä#*å#lCpython3-jwcrypto0.7bp157.2.6.1Python module package implementing JOSE Web standardsA Python implementation of the JOSE Working Group documents: RFC 7515 - JSON Web Signature (JWS) RFC 7516 - JSON Web Encryption (JWE) RFC 7517 - JSON Web Key (JWK) RFC 7518 - JSON Web Algorithms (JWA) RFC 7519 - JSON Web Token (JWT) RFC 7520 - Examples of Protecting Content Using JSON Object Signing and Encryption (JOSE)j—î(i03-ch1c\jSUSE Linux Enterprise 15openSUSELGPL-3.0-onlyhttp://bugs.opensuse.orgDevelopment/Languages/Pythonhttps://github.com/latchset/jwcryptolinuxnoarch¡| ˆˆyy†¶†¶:­:­zeze=n=n@&@& À ÀK©K©b}j\Ç‘Ü[IJ…˲”ãAíAí�¤�¤�¤�¤�¤�¤Aí�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤�¤Aí�¤Aí�¤j—îj—îj—îj—îj—îj—îj—îUŸô÷j—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îj—îW·)Äj—îj—î([3-’j—î(UŸô÷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€rootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootrootpython-jwcrypto-0.7-bp157.2.6.1.src.rpmÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿpython3-jwcrypto@     python(abi)python3-cryptographyrpmlib(CompressedFileNames)rpmlib(FileDigests)rpmlib(PartialHardlinkSets)rpmlib(PayloadFilesHavePrefix)rpmlib(PayloadIsXz)3.63.0.4-14.6.0-14.0.4-14.0-15.2-14.14.3j˜ÀiÞ,@^�ß@\”Î@\l@[3|@[0Ù@Yž¿ÀYƒ@Yuá@XB³ÀX%²ÀNico Krapp Nico Krapp Michael Ströder Michael Ströder Matej Cepl michael@stroeder.commcepl@suse.comjmatejek@suse.commichael@stroeder.commichael@stroeder.commichael@stroeder.commichael@stroeder.com- CVE-2026-80179: Denial of Service via malformed JWE tokens (bsc#1277639) * added CVE-2026-80179.patch- CVE-2022-3102: jwcrypto token substitution can lead to authentication bypass (bsc#1209496) * added CVE-2022-3102.patch - CVE-2023-6681: denial of service Via specifically crafted JWE (bsc#1219837) * added CVE-2023-6681.patch - CVE-2024-28102: malicious JWE token can cause denial of service (bsc#1221230) * added CVE-2024-28102.patch - CVE-2026-39373: Memory exhaustion via crafted compressed JWE tokens (bsc#1261802) * added CVE-2026-39373.patch- update to upstream release 0.7.0 * Allow to use JWKSet on a JWT with no KID * Fixed JWE jose_header * Added JWE/JWS custom registry header implementation * RFC 8037 - Support for Ed25519, Ed448 * Stricter OKP key generation parms check * Add X25519/X448 support * Simplify internal code curve selection * Fix encoding length of EC keys Coordinates * Add the ability to verify 'none' signatures * Import ABC from collections.abc instead of collections for Python 3.9 compatibility- update to upstream release 0.6.0 * Use python-cryptography's AES key wrapping * Add tests for key wrapping where CEK < KEK * Fix ECDH-ES key exchange for CEK greater than KEK * Add support for RFC7797 * Fix JWK.from_json- Remove superfluous devel dependency for noarch package- update to upstream release 0.5.0: * Better validation of JWE * Avoid deprecation warnings * Tested to work with python 3.7- Clean SPEC file- singlespec auto-conversion- update to upstream release 0.4.2- update to upstream release 0.4.1- update to upstream release 0.4.0- initial package of upstream release 0.3.1i03-ch1c 1788341800  !"#$%&'0.7-bp157.2.6.1jwcryptojwcrypto-0.7-py3.6.egg-infoPKG-INFOSOURCES.txtdependency_links.txtrequires.txttop_level.txt__init__.py__pycache____init__.cpython-36.opt-1.pyc__init__.cpython-36.pyccommon.cpython-36.opt-1.pyccommon.cpython-36.pycjwa.cpython-36.opt-1.pycjwa.cpython-36.pycjwe.cpython-36.opt-1.pycjwe.cpython-36.pycjwk.cpython-36.opt-1.pycjwk.cpython-36.pycjws.cpython-36.opt-1.pycjws.cpython-36.pycjwt.cpython-36.opt-1.pycjwt.cpython-36.pyctests-cookbook.cpython-36.opt-1.pyctests-cookbook.cpython-36.pyctests.cpython-36.opt-1.pyctests.cpython-36.pyccommon.pyjwa.pyjwe.pyjwk.pyjws.pyjwt.pytests-cookbook.pytests.pypython3-jwcryptoREADME.mdpython3-jwcryptoLICENSE/usr/lib/python3.6/site-packages//usr/lib/python3.6/site-packages/jwcrypto-0.7-py3.6.egg-info//usr/lib/python3.6/site-packages/jwcrypto//usr/lib/python3.6/site-packages/jwcrypto/__pycache__//usr/share/doc/packages//usr/share/doc/packages/python3-jwcrypto//usr/share/licenses//usr/share/licenses/python3-jwcrypto/-fomit-frame-pointer -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protectionobs://build.opensuse.org/openSUSE:Maintenance:19677/openSUSE_Backports_SLE-15-SP7_Update/6a9b88d4f9a77dafa14a02162bd7d366-python-jwcrypto.openSUSE_Backports_SLE-15-SP7_Updatedrpmxz5noarch-suse-linuxdirectoryASCII textemptypython 3.6 byte-compiledPython script, ASCII text executable RRRRRRRRRRRRRRRRRRRRRRRRRRRª§ £}, ri ¢ù�‚Óutf-80a55e9bc4737fa08d404e3813c092d51753857a9b413c01e528984570d661d2c?ÿÿü ý7zXZ áû ¡!t/å£à Þ<]"ÌkÀ%�„pµa¥ ‚Ã…®ÕR?¢æGÜbÀKfÓ_ûÁão{Âò>›�õÝ· R�MÏ�ÖJõ¾d)³D‰dûŒ’©yÙnÙ.-—N„¶^ù�C˜¯�²‡÷ÜÖwÿ]ªTkŹYæ³¢6ŒF勾eâ3ÓÞ2¡Ý9‹8K;ï�²}¹aØSð;€†T‹ªÂ¬LЫÒ!ÑxL+åWcwd‚ ç!µñ#´UÙkè Ò &(2Äí¬,Ôžç.rhnÐù‹ÀM8mÞX˜Í:–«×ó@1énˆD?¯p»m>6€AVŽNóÍk�u ¿ó�×P?Þ±àbÑòÍY¤vkèÊ]} °²‰ÂW��ŽÞ¼WýÞ¡é^ìN!1ù¼ºë¹•~au¡qSlâ`í÷Yó!Ù«(ͶÝÙ|NgçAÊ7äÒØ“‹ÓCXÓ#ôqö]ï�¶F€+OÎëQÈí>¸mpÑ�ß¼ϺR€»7×µ8�áCÏã×ÙÞƒãyb�NZ8Wl† µ¦«¼èÙªýâsJxW˜}º"ìV7�NGƌح^|r=rÚ÷½˜EY‹&O å¤_­ÏäHÏŃl­½¨·«‡²®:5þ—ùÎ"Zë$ªŽb=²9׺ ÊÙÚÚófؼd�æðé\ˆ–Ûvûñ_Ð3TAÇF àŒ¥°ê>‰ÌtìÞ!áe€À ö)Ímƒ¢pìf¦aÖ<9µ& £=!Å3¤ìŒDQ|Ô=ÿæ=Í9§ ’ÝZª+ã^W·¾o©ÀrqtÊ™ýð×ä þ›´[óçQ… Åðµ=(W£u±¾á�¨¶6sÿ“A°áZI3a·ÖBž=ÑG]­Å¿ÞÇ{ q|?Áêu¼wÀ¬pöûˆ'PÀÍãè×Lå&ƒ_=¸GbIÿl÷N¿Çÿù�¨>PÉe°W[ßDôóõD¸íÅBœ«ƒKJ³p¿Ÿ<¤ÅEù½ÁX�Å_ÇŒ_FU/½Ï®m¯§‡x6=ho©±›pñ6$™‚ð®Wqñýß§è}ð‰•ª1G�M­Ž¿›[˜Ñ Ïåÿl{=®—CË,vI�¤µP·ë²É|êxÿìçç«-YV¼ÍGĘ˜âØF…¾0-¤³ì²LôF—ƒµÊ2Ϭ©ÎáÙFxv(XÁ�­%«{ÉJùßgnKé�1]ks¨až×XôŠ¢NíO’È·«<(¹OAf@õ×4 G±ûˆ»ÇW›ïI9/Q�¬½“8òòP/aÈçôÁ¡;Jóíð±/\Ôƒ€4Îø—)ˆðÂ2<åXz"ܰ‘÷‚xÇã¸5�v{V‰©¾öq¡ÓBZ3ï¬ýã=©¦…%Ç‹¸T†i ýyÄ\òän€v'ïŽ@ê¿EL'¶=÷:A�³7”ÿ:»ÖJ µ´Ù4\䵈«Œ+yâ~¹Ë½“1Ì÷@sJ âä¸Ìn<ÈßW÷ zÖØ.I(‰!CµË·„BcˆNÏNûÚíåH×zìJïÃØoÎØÍ6š'{bŠ‘ó5+/µ}XJM°¾HÆèˆ ÕOt!q]dF¬g5F·vU ø`ÍHÝ:5[Az?>PU«�Qli>îXÀ•-Z§Ó ·M�——ï³@€×MDÊÜç~”lòM8U}—ª#�âö­¬òÜùMÃó~é„f<žÏ‰—9Æ} •âUr²¦ÆvmÕ•tŒõÃü846 ®"yã÷F‹ S :nù“Ã&ˆòhÞ0“b{§ôxêB�ôÄ6ó=ïÆ¾°ËŠ­ÇPî}àN�À¼J¢¯,Ý•¦OiÔ¡å=…\¥×ñÂSÞØà”fÒ×ÿù-ؾ‚lâ“Pô(zÙ7V¨•á±ßüö¢¸Ö›éåwû€ž,_¹¸MfŸô©Ë.\Ì&Å"±Þ·ŠTÛ¯ ž&À¬ëy.½)‘€=-“ˆ]£F“,1¼ŒÊ>#?éu¸§ëõÆÿÔÒ’§mXëZªLó$¦hËjÀ"Ê1MA6 $‡¾ŒïQ=Õí Ïy’x¦QðX¤ÄÂ6\£Eyª5ı/¬ŽJ~09-<ñr?8¢psDÕ7T´+S=¯QÏgT(XeïßRÚùyâ�ÿ1Âw A‹Õ ÝTYóòÎ%ž’ñ—²èVjÆúx‰å=Ñô¾i¯4‘”}ͧIbÿòè$³8 ›ð;€b~Fe(n•æ!¢SÌÖ�«a‚à4ÖÚ®€ÆôAÌž¿ØÕ³«|ÓY«¼sÚ ,^€0âÐin{4-Äöõ’øÚóa6ªgª¯LA 3`Ž7óUœ”èb£¼/ø´Ÿi�!¢ûeCûˆô1¨O`éZÞ ÇN抇ñà^vw“¢ÙèE›…A�²* X[n´$W{ —™ÿDb<Î`‰SïvÙZa.¥”UrRP�2qêµhÏ&“÷šWü�—ÆfP=–=ÇÜl6›dŬ‹å‡ … ¸ûÊl‹­ûbá0ÝPœGeÂ3ÓÝ:R¸r;�bø¥i -[´}HÒ f M>m•û'UMƒçû¬8K ¯ßžÔ!¶Ý�§ˆò>FËÀØžð]ÜEiwüñKItª²â*lU$µ\8&³±‡óþV(í â‰ô8ËÇ?,ù;´s|¬ug˜!�1V# ¡4AgU×·æÏZëÓT9x£V¦Œ4�»Z{%ÐÂTo£0äNÄXÕQºøX›ƒ—•ÚÚ •i|U3œ©ø2„íÅ@Ó1¨àÃî™wQùŸqþ¨ìÉw Ä¼ÏðVixÚçžhsf%ç®ÜÏçã%ˆ‘dz�œÞÖ©R§g21¬²Ê`]!X¯ÆÅ'Ù‹Qsâß,DzOשæÌ€€ÒÄøš…[¶¿Zéò…oîDt£/dÖóòz~ê9{ÿD¥ñâ¥thÖc‘´K0 ä4ETÕUÀ©p‡+úR,_4+~.Âß4|;ØÏ›êùoŽ+!yX¾¼´U (S¡�åFÔ ׯ´ ÒøW…R¡w“nö¿Ú—}ÔBæ®d²p€±_¦ÿ›„ý´‰ Ëj|}E�ÅDWFåB�¥:‚ã©Ó¯´» R¸|…§„ŽÈC¹qð°š4t)7ÙµŽWªüMqÔâ œk¿5ôX–h䓸N%¹@YcÂ){õ¯%ŠÜa$ÝpMKFã«Ú“PãþÐ5c˲€õ¾Æ?öSùU$¢¥L€ßà^<Ü'2rªð|(öÕQ"%ºÐ¤$ñ¯\GòÙBˆñ°‘4ú¾9ô¬ÏÖó}xüÍ'¯­v�êº)­Ì–¥J«–+É»ÍÆ×]Á¿ÀZûTÐü/žª²*� íg·Dhã.WŽzºxÇÐBÇú„¹\ Q�B ¤P<Ø@³Í4h+{Œ‹“ٞΒ)?}¢�üñO½Ò…ì™ éþW^ÏNXM~°£af‘\8¨™€™�‚¤ŠþÅIøï­À±eL©—é‹¥´þ@B>ÛÝ�¬|Ìcƒ5aÉ®ðöÍÌ£2©�/pŸ5ÐêY<ù�¢2,pei'«_Ô�øyމS*o[¶P¹iöDàÚ¥³¥øSÑ 9çÕÙI,*“k)Ì5Q†]å™"Ópkg«rÓ2þæ0: }°}¥µdëËžFq¡ ¦‘°µk¯‹Ï>¹R-žLOèmwMßM˜æPT›O«Õ@œƒh8Á�\#³x$p±ø§§FÂwZ* §C`o2™iØ6*Qâ”øGÍÖ›:ü¥'h÷^ŠáÇèG˜µ`Ű³sÈó,Vqå\mQ™üqÈæõå×èÞÚ5f+Yþm½­eÎÌveÁbÈÂ-¢8 tæþ•˜ ¯r6Û£`ªïZ¤ƒ­#õ>·˜ÛTÅ>têù´Ä&5·òðµùýã~û·�¨J)ÀÛsb1‘2\Õ:O”]ÌæÖ õG½®¯›©OQì�Ëiíµ…„M@Ïz.XÊÎ4fÔdº÷­T”íqÌßÛÑž iZšÛãæm‡ŒxçŠ|„NÃ&Û†0r0™ñê`ª¸È”ñ�!©Jµ‚R¦¡fŠes”ýIÉÓ¯vàräI‘ÌcÍ�Ty|dwWïÒ:*º gëeæÒ)bÅ[lÒŸ£¦öni‘ŸŠ$º5ÒÎ0P»ý­ò|…-‰)5~=«<èN¤!4Y4‰z >Ñ0eš/)gÓÂy7·SÎÒow‡£û–OϹøµ—NïÊ–ÑeI]›ÿA= ¸ÃKã��Ë07>v`Ԁ͓’gíÇJtV€ô.�³7‘9�§~à_7©XÂÕ”+RVïôpæÑóš3í˜X޲Tt¼5hŽÅÌö¼ÓÌɽ[¾™pÝÀR•ƒj@tE]KÕC/ay‰8hzÐõ za-KÆ;n#pH’Þ=ûû§ONðßAù¸|¶éß YZ