Class DnsOpCode
java.lang.Object
io.netty.handler.codec.dns.DnsOpCode
- All Implemented Interfaces:
java.lang.Comparable<DnsOpCode>
-
Field Summary
FieldsModifier and TypeFieldDescriptionprivate final bytestatic final DnsOpCodeThe 'IQuery' DNS OpCode, as defined in RFC1035.private final java.lang.Stringstatic final DnsOpCodeThe 'Notify' DNS OpCode, as defined in RFC1996.static final DnsOpCodeThe 'Query' DNS OpCode, as defined in RFC1035.static final DnsOpCodeThe 'Status' DNS OpCode, as defined in RFC1035.private java.lang.Stringstatic final DnsOpCodeThe 'Update' DNS OpCode, as defined in RFC2136. -
Constructor Summary
Constructors -
Method Summary
Methods inherited from class java.lang.Object
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
-
Field Details
-
QUERY
-
IQUERY
-
STATUS
-
NOTIFY
-
UPDATE
-
byteValue
private final byte byteValue -
name
private final java.lang.String name -
text
private java.lang.String text
-
-
Constructor Details
-
DnsOpCode
private DnsOpCode(int byteValue) -
DnsOpCode
public DnsOpCode(int byteValue, java.lang.String name)
-
-
Method Details
-
valueOf
-
byteValue
public byte byteValue() -
hashCode
public int hashCode()- Overrides:
hashCodein classjava.lang.Object
-
equals
public boolean equals(java.lang.Object obj) - Overrides:
equalsin classjava.lang.Object
-
compareTo
-
toString
public java.lang.String toString()- Overrides:
toStringin classjava.lang.Object
-