Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: libregexp-common-perl
Source: <url://example.com>
#
# Please double check copyright with the licensecheck(1) command.

Files:     COPYRIGHT.AL
           Changes
           MANIFEST
           META.json
           META.yml
           Makefile.PL
           TODO
           t/Common.pm
           t/SEN/usa_ssn.t
           t/URI/any.t
           t/URI/fax.t
           t/URI/file.t
           t/URI/ftp.t
           t/URI/gopher.t
           t/URI/http.t
           t/URI/news.t
           t/URI/nntp.t
           t/URI/pop.t
           t/URI/prospero.t
           t/URI/tel.t
           t/URI/telnet.t
           t/URI/tv.t
           t/URI/wais.t
           t/comment/delimited.t
           t/comment/html.t
           t/comment/nested.t
           t/comment/pascal.t
           t/comment/single_line.t
           t/comment/single_or_multiline.t
           t/delimited/101_delimited.t
           t/delimited/111_bquoted.t
           t/net/101_ipv4.t
           t/net/102_ipv4_strict.t
           t/net/111_ipv6.t
           t/net/121_mac.t
           t/net/131_domain.t
           t/number/101_integer.t
           t/number/111_integer_base.t
           t/number/121_integer_places.t
           t/number/122_integer_places.t
           t/number/123_integer_places.t
           t/number/131_integer_sep.t
           t/number/141_integer_group.t
           t/number/701_squares.t
           t/number/801_roman.t
           t/number/decimal.t
           t/number/number.t
           t/test___luhn.t
           t/test_balanced.t
           t/test_bases.t
           t/test_bases_sep.t
           t/test_comments.t
           t/test_curry.t
           t/test_i.t
           t/test_lingua_palindrome.t
           t/test_list.t
           t/test_no_import.t
           t/test_profanity.t
           t/test_sub.t
           t/test_sub_named.t
           t/test_ws.t
           t/zip/101_austria.t
           t/zip/111_australia.t
           t/zip/112_australia.t
           t/zip/121_belgium.t
           t/zip/131_denmark.t
           t/zip/141_greenland.t
           t/zip/151_norway.t
           t/zip/161_liechtenstein.t
           t/zip/171_switzerland.t
           t/zip/181_italy.t
           t/zip/191_germany.t
           t/zip/201_luxembourg.t
           t/zip/211_france.t
           t/zip/221_monaco.t
           t/zip/231_san-marino.t
           t/zip/241_vatican-city.t
           t/zip/Zip.pm
           t/zip/netherlands.t
           t/zip/spain.t
           t/zip/us.t
           t/zip/zip.t
Copyright: __NO_COPYRIGHT_NOR_LICENSE__
License:   __NO_COPYRIGHT_NOR_LICENSE__

Files:     COPYRIGHT
           README
           lib/Regexp/Common.pm
           lib/Regexp/Common/CC.pm
           lib/Regexp/Common/SEN.pm
           lib/Regexp/Common/URI.pm
           lib/Regexp/Common/URI/RFC1035.pm
           lib/Regexp/Common/URI/RFC1738.pm
           lib/Regexp/Common/URI/RFC1808.pm
           lib/Regexp/Common/URI/RFC2384.pm
           lib/Regexp/Common/URI/RFC2396.pm
           lib/Regexp/Common/URI/RFC2806.pm
           lib/Regexp/Common/URI/fax.pm
           lib/Regexp/Common/URI/file.pm
           lib/Regexp/Common/URI/ftp.pm
           lib/Regexp/Common/URI/gopher.pm
           lib/Regexp/Common/URI/http.pm
           lib/Regexp/Common/URI/news.pm
           lib/Regexp/Common/URI/pop.pm
           lib/Regexp/Common/URI/prospero.pm
           lib/Regexp/Common/URI/tel.pm
           lib/Regexp/Common/URI/telnet.pm
           lib/Regexp/Common/URI/tv.pm
           lib/Regexp/Common/URI/wais.pm
           lib/Regexp/Common/_support.pm
           lib/Regexp/Common/balanced.pm
           lib/Regexp/Common/comment.pm
           lib/Regexp/Common/delimited.pm
           lib/Regexp/Common/lingua.pm
           lib/Regexp/Common/list.pm
           lib/Regexp/Common/net.pm
           lib/Regexp/Common/number.pm
           lib/Regexp/Common/profanity.pm
           lib/Regexp/Common/whitespace.pm
Copyright: __NO_COPYRIGHT__ in: COPYRIGHT
           __NO_COPYRIGHT__ in: README
           __NO_COPYRIGHT__ in: lib/Regexp/Common.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/CC.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/SEN.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/RFC1035.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/RFC1738.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/RFC1808.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/RFC2384.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/RFC2396.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/RFC2806.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/fax.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/file.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/ftp.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/gopher.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/http.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/news.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/pop.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/prospero.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/tel.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/telnet.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/tv.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/URI/wais.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/_support.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/balanced.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/comment.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/delimited.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/lingua.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/list.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/net.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/number.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/profanity.pm
           __NO_COPYRIGHT__ in: lib/Regexp/Common/whitespace.pm
License:   __UNKNOWN__
 This module is free software, and maybe used under any of the following
 licenses:
 .
 1) The Perl Artistic License.     See the file COPYRIGHT.AL.
 2) The Perl Artistic License 2.0. See the file COPYRIGHT.AL2.
 3) The BSD License.               See the file COPYRIGHT.BSD.
 4) The MIT License.               See the file COPYRIGHT.MIT.

Files:     COPYRIGHT.MIT
Copyright: 2001-2008 Damian Conway and Abigail
License:   Expat
 Permission is hereby granted, free of charge, to any person obtaining a copy
 of this software and associated documentation files (the "Software"), to deal
 in the Software without restriction, including without limitation the rights
 to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
 copies of the Software, and to permit persons to whom the Software is
 furnished to do so, subject to the following conditions:
 .
 The above copyright notice and this permission notice shall be included in
 all copies or substantial portions of the Software.
 .
 THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
 IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
 FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
 AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
 LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
 OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
 THE SOFTWARE.

Files:     COPYRIGHT.AL2
Copyright: 2000-2006 The Perl Foundation.
License:   __HEADER___
 Everyone is permitted to copy and distribute verbatim copies of this
 license document, but changing it is not allowed.
 .
 Preamble
 .
 This license establishes the terms under which a given free software
 Package may be copied, modified, distributed, and/or redistributed. The
 intent is that the Copyright Holder maintains some artistic control over
 the development of that Package while still keeping the Package
 available as open source and free software.
 .
 You are always permitted to make arrangements wholly outside of this
 license directly with the Copyright Holder of a given Package. If the
 terms of this license do not permit the full use that you propose to
 make of the Package, you should contact the Copyright Holder and seek a
 different licensing arrangement.
 .
 Definitions
 .
 "Copyright Holder" means the individual(s) or organization(s) named in
 the copyright notice for the entire Package.
 .
 "Contributor" means any party that has contributed code or other
 material to the Package, in accordance with the Copyright Holder's
 procedures.
 .
 "You" and "your" means any person who would like to copy, distribute, or
 modify the Package.
 .
 "Package" means the collection of files distributed by the Copyright
 Holder, and derivatives of that collection and/or of those files. A
 given Package may consist of either the Standard Version, or a Modified
 Version.
 .
 "Distribute" means providing a copy of the Package or making it
 accessible to anyone else, or in the case of a company or organization,
 to others outside of your company or organization.
 .
 "Distributor Fee" means any fee that you charge for Distributing this
 Package or providing support for this Package to another party. It does
 not mean licensing fees.
 .
 "Standard Version" refers to the Package if it has not been modified, or
 has been modified only in ways explicitly requested by the Copyright Holder.
 .
 "Modified Version" means the Package, if it has been changed, and such
 changes were not explicitly requested by the Copyright Holder.
 .
 "Original License" means this Artistic License as Distributed with the
 Standard Version of the Package, in its current version or as it may be
 modified by The Perl Foundation in the future.
 .
 "Source" form means the source code, documentation source, and
 configuration files for the Package.
 .
 "Compiled" form means the compiled bytecode, object code, binary, or any
 other form resulting from mechanical transformation or translation of
 the Source form.
 .
 Permission for Use and Modification Without Distribution
 .
 (1) You are permitted to use the Standard Version and create and use
 Modified Versions for any purpose without restriction, provided that you
 do not Distribute the Modified Version.
 .
 Permissions for Redistribution of the Standard Version
 .
 (2) You may Distribute verbatim copies of the Source form of the
 Standard Version of this Package in any medium without restriction,
 either gratis or for a Distributor Fee, provided that you duplicate all
 of the original copyright notices and associated disclaimers. At your
 discretion, such verbatim copies may or may not include a Compiled form
 of the Package.
 .
 (3) You may apply any bug fixes, portability changes, and other
 modifications made available from the Copyright Holder. The resulting
 Package will still be considered the Standard Version, and as such will
 be subject to the Original License.
 .
 Distribution of Modified Versions of the Package as Source
 .
 (4) You may Distribute your Modified Version as Source (either gratis or
 for a Distributor Fee, and with or without a Compiled form of the
 Modified Version) provided that you clearly document how it differs from
 the Standard Version, including, but not limited to, documenting any
 non-standard features, executables, or modules, and provided that you do
 at least ONE of the following:
 .
 (a) make the Modified Version available to the Copyright Holder of the
 Standard Version, under the Original License, so that the Copyright
 Holder may include your modifications in the Standard Version.
 (b) ensure that installation of your Modified Version does not prevent
 the user installing or running the Standard Version. In addition, the
 Modified Version must bear a name that is different from the name of the
 Standard Version.
 (c) allow anyone who receives a copy of the Modified Version to make the
 Source form of the Modified Version available to others under
 (i) the Original License or
 (ii) a license that permits the licensee to freely copy, modify and
 redistribute the Modified Version using the same licensing terms that
 apply to the copy that the licensee received, and requires that the
 Source form of the Modified Version, and of any works derived from it,
 be made freely available in that license fees are prohibited but
 Distributor Fees are allowed.
 Distribution of Compiled Forms of the Standard Version or Modified
 Versions without the Source
 .
 (5) You may Distribute Compiled forms of the Standard Version without
 the Source, provided that you include complete instructions on how to
 get the Source of the Standard Version. Such instructions must be valid
 at the time of your distribution. If these instructions, at any time
 while you are carrying out such distribution, become invalid, you must
 provide new instructions on demand or cease further distribution. If you
 provide valid instructions or cease distribution within thirty days
 after you become aware that the instructions are invalid, then you do
 not forfeit any of your rights under this license.
 .
 (6) You may Distribute a Modified Version in Compiled form without the
 Source, provided that you comply with Section 4 with respect to the
 Source of the Modified Version.
 .
 Aggregating or Linking the Package
 .
 (7) You may aggregate the Package (either the Standard Version or
 Modified Version) with other packages and Distribute the resulting
 aggregation provided that you do not charge a licensing fee for the
 Package. Distributor Fees are permitted, and licensing fees for other
 components in the aggregation are permitted. The terms of this license
 apply to the use and Distribution of the Standard or Modified Versions
 as included in the aggregation.
 .
 (8) You are permitted to link Modified and Standard Versions with other
 works, to embed the Package in a larger work of your own, or to build
 stand-alone binary or bytecode versions of applications that include the
 Package, and Distribute the result without restriction, provided the
 result does not expose a direct interface to the Package.
 .
 Items That are Not Considered Part of a Modified Version
 .
 (9) Works (including, but not limited to, modules and scripts) that
 merely extend or make use of the Package, do not, by themselves, cause
 the Package to be a Modified Version. In addition, such works are not
 considered parts of the Package itself, and are not subject to the terms
 of this license.
 .
 General Provisions
 .
 (10) Any use, modification, and distribution of the Standard or Modified
 Versions is governed by this Artistic License. By using, modifying or
 distributing the Package, you accept this license. Do not use, modify,
 or distribute the Package, if you do not accept this license.
 .
 (11) If your Modified Version has been derived from a Modified Version
 made by someone other than you, you are nevertheless required to ensure
 that your Modified Version complies with the requirements of this license.
 .
 (12) This license does not grant you the right to use any trademark,
 service mark, tradename, or logo of the Copyright Holder.
 .
 (13) This license includes the non-exclusive, worldwide, free-of-charge
 patent license to make, have made, use, offer to sell, sell, import and
 otherwise transfer the Package with respect to any patent claims
 licensable by the Copyright Holder that are necessarily infringed by the
 Package. If you institute patent litigation (including a cross-claim or
 counterclaim) against any party alleging that the Package constitutes
 direct or contributory patent infringement, then this Artistic License
 to you shall terminate on the date that such litigation is filed.
 .
 (14) Disclaimer of Warranty: THE PACKAGE IS PROVIDED BY THE COPYRIGHT
 HOLDER AND CONTRIBUTORS "AS IS' AND WITHOUT ANY EXPRESS OR IMPLIED
 WARRANTIES. THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
 PARTICULAR PURPOSE, OR NON-INFRINGEMENT ARE DISCLAIMED TO THE EXTENT
 PERMITTED BY YOUR LOCAL LAW. UNLESS REQUIRED BY LAW, NO COPYRIGHT HOLDER
 OR CONTRIBUTOR WILL BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, OR
 CONSEQUENTIAL DAMAGES ARISING IN ANY WAY OUT OF THE USE OF THE PACKAGE,
 EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Files:     lib/Regexp/Common/zip.pm
Copyright: __NO_COPYRIGHT__ in: lib/Regexp/Common/zip.pm
License:   __UNKNOWN__
 This module is free software, and maybe used under any of the following
 __MANY_TOTAL_LINES__(3276lines) truncating at: licenses:
 licenses:
 __MANY_TOTAL_LINES__(3277lines) truncating at:
 .
 __MANY_TOTAL_LINES__(3278lines) truncating at:  1) The Perl Artistic License.     See the file COPYRIGHT.AL.
 1) The Perl Artistic License.     See the file COPYRIGHT.AL.
 __MANY_TOTAL_LINES__(3279lines) truncating at:  2) The Perl Artistic License 2.0. See the file COPYRIGHT.AL2.
 2) The Perl Artistic License 2.0. See the file COPYRIGHT.AL2.
 __MANY_TOTAL_LINES__(3280lines) truncating at:  3) The BSD License.               See the file COPYRIGHT.BSD.
 3) The BSD License.               See the file COPYRIGHT.BSD.
 __MANY_TOTAL_LINES__(3281lines) truncating at:  4) The MIT License.               See the file COPYRIGHT.MIT.
 4) The MIT License.               See the file COPYRIGHT.MIT.
 __MANY_TOTAL_LINES__(3282lines) truncating at:
 .
 __MANY_TOTAL_LINES__(3283lines) truncating at: =cut

Files:     COPYRIGHT.BSD
Copyright: 2001-2008 Damian Conway and Abigail
License:   BSD-3-Clause
 Redistribution and use in source and binary forms, with or without
 modification, are permitted provided that the following conditions
 are met:
 .
 * Redistributions of source code must retain the above copyright
 notice, this list of conditions and the following disclaimer.
 * Redistributions in binary form must reproduce the above
 copyright notice, this list of conditions and the following disclaimer
 in the documentation and/or other materials provided with the
 distribution.
 * The names of its contributors may not be used to endorse or promote
 products derived from this software without specific prior
 written permission.
 .
 THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
 "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
 LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
 A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
 OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
 SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
 TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
 PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
 LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
 NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 .
 On Debian systems, the complete text of the BSD 3-clause "New" or "Revised"
 License can be found in `/usr/share/common-licenses/BSD'.

#----------------------------------------------------------------------------
# Files marked as NO_LICENSE_TEXT_FOUND may be covered by the following
# license/copyright files.

#----------------------------------------------------------------------------
# License file: LICENSE
 This software is Copyright (c) 2001 - 2008, Damian Conway and Abigail.
 .
 This module is free software, and maybe used under any of the following
 licenses:
 .
  1) The Perl Artistic License.     See the file COPYRIGHT.AL.
  2) The Perl Artistic License 2.0. See the file COPYRIGHT.AL2.
  3) The BSD License.               See the file COPYRIGHT.BSD.
  4) The MIT License.               See the file COPYRIGHT.MIT.
